Under the urging of Mojo Jojo I have taken the equivilant of a shotgun to my /usr/lib.

"just use rpm --nodeps --force if you really want to install it" he said.

well the end result is that I have no perl. I might be gone for a while, but my computer is not incapacitated yet, I don't think i'll be able to reboot though.

Okay I almost have perl re-installed but things are in my way!

[root@ragu] (/home/Shan)# rpm -Uvh perl-5.6.0-9.i386.rpm
error: failed dependencies:
        libdb-3.1.so is needed by perl-5.6.0-9
        libc.so.6(GLIBC_2.1.3) is needed by perl-5.6.0-9
        libc.so.6(GLIBC_2.2) is needed by perl-5.6.0-9


libdb-3.1.so should be in GLIBC along with all of that other crap, right? well... lets put it this way, I don't like rpm, and rpm doesn't like me.

scream!

[root@ragu] (/home/Shan)# rpm -Uvh glibc-2.1.94-3.i386.rpm
error: failed dependencies:
        rpm <= 4.0-0.65 conflicts with glibc-2.1.94-3
        libdb.so.2 is needed by enlightenment-conf-0.15-5
        libdb.so.2 is needed by gedit-0.5.1-3
        libdb.so.2 is needed by gnome-linuxconf-0.22-1
        libdb.so.2 is needed by gnorpm-0.8-5
        libdb.so.2 is needed by python-1.5.1-10
        libdb.so.2 is needed by sendmail-8.9.3-10
        libdb.so.2 is needed by wmconfig-0.9.5-1
        libdb.so.2 is needed by control-center-1.0.51-1
        libdb.so.2 is needed by ee-0.3.11-1
        libdb.so.2 is needed by extace-1.2.1-1
        libdb.so.2 is needed by gdm-2.0beta2-13
        libdb.so.2 is needed by gmc-4.5.40-1
        libdb.so.2 is needed by gnome-core-1.0.53-2
        libdb.so.2 is needed by gnome-games-1.0.51-1
        libdb.so.2 is needed by gnome-libs-1.0.53-1
        libdb.so.2 is needed by gnome-media-1.0.51-1
        libdb.so.2 is needed by gnome-pim-1.0.50-1
        libdb.so.2 is needed by gnome-utils-1.0.50-1
        libdb.so.2 is needed by gnumeric-0.38-8
        libdb.so.2 is needed by gtk---1.0.3-1
        libdb.so.2 is needed by gtop-1.0.5-1
        libdb.so.2 is needed by libglade-0.7-1
        libdb.so.2 is needed by pygnome-1.0.50-1
        libdb.so.2 is needed by gnome-chess-0.2.3-1
        libdb.so.2 is needed by glade-0.5.3-1
        libdb.so.2 is needed by rpmfind-1.2-1
        libdb.so.2 is needed by rpm-3.0.5-9.6x
        libdb.so.2(GLIBC_2.0) is needed by gnorpm-0.8-5
        libdb.so.2(GLIBC_2.0) is needed by python-1.5.1-10
        libdb.so.2(GLIBC_2.0) is needed by sendmail-8.9.3-10
        libdb.so.2(GLIBC_2.0) is needed by gnome-libs-1.0.53-1
        libdb.so.2(GLIBC_2.0) is needed by rpm-3.0.5-9.6x
        libdb.so.3 is needed by python-1.5.1-10
        libdb.so.3 is needed by xchat-1.4.2-1
        libdb.so.3 is needed by xemacs-21.1.3-1
        libdb.so.3(GLIBC_2.0) is needed by python-1.5.1-10
        libdb.so.3(GLIBC_2.1) is needed by xemacs-21.1.3-1