People rightly found that terminology incredibly confusing, so they changed the naming convention to top-level nested class and inner class. The JVM attributes had already been defined in the spec, so these names couldn't be changed. It's another wart on the Java language, like the super bit on classes that is a workaround for a bug in JDK 1.0, but it's nothing to get upset about.
It is worth pointing out this new terminology because having a mixture of the old and new terminologies is even more confusing than the already confusing old terminology.
Thanks to schapel of the JDC for
bringing up this bit of knowledge.